TBS6903 not starting in SmartDVB

Squiffy

New member
Messages
23
Just put together a new PC (Windows 10) and decided to buy the TBS6903 for it. Unfortunately, after selecting the card, it doesn't start, although SmartDVB then runs fine.
I've tried v0.5.3 (x64) and a few previous versions, but get the same result.

It works okay on ProgDVB and DVB Dream, but of course they're not free. I've always preferred SmartDVB, so want to use that if possible. Any suggestions welcome.

This is the relevant section from the SmartDVB log file:

13:33:04 - [0000 00017 00017391]: CDV::SELECTDEVICE 0 - TBS 6903 DVBS/S2 Tuner 0
13:33:05 - [0000 00018 00018391]: CStreamreader:: DevicePath set to \\?\pci#ven_544d&dev_6178&subsys_00016903&rev_00#6&15a14a97&0&0030020a#{71985f48-1ca1-11d3-9cc8-00c04f7971e0}\{1f7c3bfb-f6dd-
13:33:05 - [0000 00018 00018391]: Client receiver Failed in read server command size Error:995
13:33:05 - [0000 00018 00018391]: CMDAPIClientHandler::AVThread error reading packet (error count 1)
13:33:05 - [0000 00018 00018391]: CMDAPIClientHandler::StopHandler CancelIO Ok
13:33:05 - [0000 00018 00018907]: StartMDAPIClient:: Starting Client
13:33:05 - [0000 00018 00018907]: StartMDAPIClient::CreateProcess Starting C:\Program Files\SmartDVB64\mdapi\mdapihost.exe
13:33:05 - [0000 00018 00018907]: >> StartMDAPIClients: restarting MDAPI clients on ERROR
13:33:05 - [0000 00018 00018907]: CMDAPIClientHandler::StartMDAPIClient called for \\?\pci#ven_544d&dev_6178&subsys_00016903&rev_00#6&15a14a97&0&0030020a#{71985f48-1ca1-11d3-9cc8-00c04f7971e0}\{1f7c3bfb-f6dd- 0
13:33:05 - [0000 00018 00018907]: CMDAPIClientHandler::StartMDAPIClient Client not found adding
13:33:05 - [0000 00018 00018907]: >> CMDAPIClientHandler::AVThread Started
13:33:05 - [0000 00018 00018922]: Failed to select Device (bdas.dev) TBS 6903 DVBS/S2 Tuner 0
13:33:05 - [0000 00018 00018922]: Error starting device TBS 6903 DVBS/S2 Tuner 0 [Device ID : 0]


System details FWIW:
MSI MAG B550 Tomahawk motherboard, AMD Ryzen 5600X, 16GB RAM, Geforce RTX 2060 graphics card.
 

EnoSat

Well-known member
Messages
1,262
It is very similar to SmartDVB (last version from 10/2019) is AltDVB
The author was last on the forum Last visited: 13 Nov 2021, 01:03, so there will probably be no more development or corrections
 
Last edited:

Squiffy

New member
Messages
23
Thanks, but AltDVB didn't work either.
 

EnoSat

Well-known member
Messages
1,262
same problem ?
 

moonbase

Registered
Messages
36
Is the DVB app version compatible with your windows version re 32bit or 64bit?
For example, are you using Windows 32 bit O/S and trying to use the 64bit version of SmartDVB?
 

EnoSat

Well-known member
Messages
1,262
I am now use only AltDVB and DVBViewer (long time not use SmartDVB) on 64bit W11
 

Squiffy

New member
Messages
23
Is the DVB app version compatible with your windows version re 32bit or 64bit?
For example, are you using Windows 32 bit O/S and trying to use the 64bit version of SmartDVB?
Yes, 64bit version, I'm using a 64bit OS.
 

Squiffy

New member
Messages
23
same problem ?
Actually no, it was just throwing up an error and wouldn't start at all. However I've since tried the latest version of AltDVB and that appears to work fine.
 

Sunrise999

New member
Messages
17
Squiffy have a 6903 here and after setting the tuner 1 or 0 when setting the satalite I have to goto tools =devices and set the same tuner there also device settings and tbs new devises.
 

Squiffy

New member
Messages
23
Squiffy have a 6903 here and after setting the tuner 1 or 0 when setting the satalite I have to goto tools =devices and set the same tuner there also device settings and tbs new devises.
Yes, have done that, but it just won't start. Are you also using SmartDVB?
 

EnoSat

Well-known member
Messages
1,262
You can use devices from AltDVB or try modified ones from CrazyCat
 

Sunrise999

New member
Messages
17
Yes have 5 copy of Smartdvb all working are you using florian for device driver.
My 6903 is the second series does not lock high symbol rate on some 16 aspk signals on cband.
 

Squiffy

New member
Messages
23
You can use devices from AltDVB or try modified ones from CrazyCat
No luck with using any other devices either I'm afraid. Frustratingly, I cannot ask about the issue on the SmartDVB forum itself as my account hasn't been activated.
 

EnoSat

Well-known member
Messages
1,262
the author won't answer you, he hasn't been on the forum for more than two years
 

Sunrise999

New member
Messages
17
Maybe your install is corrupt only way is to reinstall make sure you remove the Smartdvb folder and check appdata to be sure nothing is there.
Reboot and install again good luck
 

Squiffy

New member
Messages
23
the author won't answer you, he hasn't been on the forum for more than two years
Yes, I've noticed that, was hoping others on there mayve have experienced the same problem and could suggest something. There still appears to be admin staff on that forum as I've seen "new members" being listed there.
 

Squiffy

New member
Messages
23
Maybe your install is corrupt only way is to reinstall make sure you remove the Smartdvb folder and check appdata to be sure nothing is there.
Reboot and install again good luck
Thanks, have tried that, still no luck.
 
Top